• Support
  • Forums
  • Blogs

No network connectivity after upgrade

aaronmartin1651aaronmartin1651

New Life Form
I performed an upgrade and after the reboot I lost all network connectivity.  The splash screen at login does give the correct IP that the device was configured with initially, so that hasn't changed.  I verified connectivity on the wires, what happened to my connectivity and how can I restore it?  Network scans do not show the device on the network any longer.

Share post:

Best Answer

  • I figured out what I had to do.  I had to flush the interfaces
    sudo ip addr flush dev eth0
    <pre style="margin-top: 0px; margin-bottom: 1em; padding: 5px; border: 0px; font-variant-numeric: inherit; font-stretch: inherit; line-height: inherit; font-family: Consolas, Menlo, Monaco, &quot;Lucida Console&quot;, &quot;Liberation Mono&quot;, &quot;DejaVu Sans Mono&quot;, &quot;Bitstream Vera Sans Mono&quot;, &quot;Courier New&quot;, monospace, sans-serif; vertical-align: baseline; width: auto; max-height: 600px; overflow: auto; word-wrap: normal;"><code style="margin: 0px; padding: 0px; border: 0px; font-style: inherit; font-variant: inherit; font-weight: inherit; font-stretch: inherit; line-height: inherit; font-family: Consolas, Menlo, Monaco, &quot;Lucida Console&quot;, &quot;Liberation Mono&quot;, &quot;DejaVu Sans Mono&quot;, &quot;Bitstream Vera Sans Mono&quot;, &quot;Courier New&quot;, monospace, sans-serif; vertical-align: baseline; white-space: inherit;">sudo ip addr flush dev eth1

    Then I brought them back up.  

    sudo ifup eth0
    sudo ifup eth1

    All is well. 

Answers

Sign In or Register to comment.